A lot of script-driven applications, particularly paid content management systems, encode their files so as to ensure that they will not be reverse engineered or tampered with. Many of them use an application named ionCube PHP Encoder to do this, so if you purchase a paid script and you would like to set it up in a hosting account, a software instrument known as ionCube Loader has to be present on the server. Without it, you cannot install the script or if you somehow find a way to do that, it will not function properly due to the fact that most of the script code will be encrypted to a degree where it can't be interpreted. That's why, you have to ensure that ionCube Loader is installed if you get a new hosting account and you would like to use some paid web application. If you purchase a shared hosting account and the instrument is not present, it can't be added as the whole server PHP environment shall have to be compiled again.

IonCube in Shared Hosting

IonCube Loader is supplied with each Linux shared hosting that we offer and you are able to activate it at any time with only a couple of clicks, so you'll be able to employ script applications which require it. You are able to do that from the PHP Configuration area of your Hepsia Control Panel and all it will take to activate or disable ionCube is to click a single button. The change takes effect within a minute, which means that you are able to go ahead and install the application that you'd like right away. The same section allows you to change the PHP release that's active for your account, as we support multiple versions on our advanced cloud platform. In case you switch to a version that you've never used to date, you'll have to activate ionCube Loader once again. More advanced users can use a php.ini file in a particular domain folder to set a PHP version different from the one for the whole account or enable/disable ionCube Loader.

IonCube in Semi-dedicated Servers

In case you aquire a semi-dedicated server package from us, you'll be able to employ any script-driven application that requires ionCube Loader as the tool is installed on all the servers which are part of our advanced cloud hosting platform. Furthermore, we support various releases of PHP, which means that if you switch from PHP 4 to 5.2 or 5.3, for instance, you can activate ionCube for that particular version with only a click in your Hepsia Control Panel. Our system will remember your decision, so if you switch back to the previous release of PHP, the tool will already be active. For more experienced users, we also provide the option to select the PHP version and whether ionCube will be active or not for a particular domain without altering the settings for the entire hosting account. This is done by putting a php.ini file in a domain folder with a few lines of code.